OSPF – xuất hiện Shortest Path First, là 1 trong giao thức định đường liên kết – state điển hình nổi bật. Đây là một trong những giao thức được sử dụng rộng rãi trong các mạng công ty có kích thước to. Trong chương trình CCNA, đó cũng là một trong những chủ thể thiết yếu được nhắc các. Do đó, nắm vững phần nhiều phép tắc buổi giao lưu của OSPF để giúp chúng ta đã theo học công tác CCNA hoàn thành xuất sắc kỳ thi đem chứng chỉ quốc tế CCNA cũng tương tự đáp ứng giỏi yêu cầu các bước vào thực tiễn.

Bạn đang xem: Ospf là gì

Một số Điểm sáng bao gồm của giao thức OSPF:

OSPF là một trong giao thức link – state điển hình. Mỗi router Lúc chạy giao thức vẫn gửi những tinh thần mặt đường liên kết của chính nó cho tất cả các router trong vùng (area). Sau một thời gian hiệp thương, những router đang đồng nhất được bảng cửa hàng tài liệu trạng thái mặt đường link (Link State Database – LSDB) cùng nhau, mỗi router đều có được “bạn dạng đồ vật mạng” của cả vùng. Từ đó từng router đang chạy giải thuật Dijkstra tính tân oán ra một cây lối đi ngắn tốt nhất (Shordemo Path Tree) và dựa vào cây này để xây hình thành bảng định tuyến.OSPF bao gồm AD = 110.Metric của OSPF còn gọi là cost, được tính theo bandwidth trên cổng chạy OSPF.OSPF chạy trực tiếp bên trên nền IP, có protocol – id là 89.OSPF là một giao thức chuẩn quốc tế, được quan niệm vào RFC – 2328.

Ta cùng Reviews hoạt động của OSPF trải qua quá trình chuyển động như sau:

Bầu chọn Router – id.Thiết lập dục tình láng giềng (neighbor).Trao đổi LSDB.Tính tân oán thi công bảng định tuyến đường.

Router – id:

Thứ nhất, lúc một router chạy OSPF, nó đề nghị chỉ ra rằng một quý giá dùng làm định danh tốt nhất đến nó vào xã hội những router chạy OSPF. Giá trị này được Điện thoại tư vấn là Router – id.

Router – id trên router chạy OSPF bao gồm định dạng của một liên can IP.. Mặc định, tiến trình OSPF trên mỗi router đã tự động bầu lựa chọn cực hiếm router – id là ảnh hưởng IPhường tối đa trong những interface đã active sầu, ưu tiên cổng loopbaông chồng.

Ta thuộc hiểu rõ ý này thông qua ví dụ:

*

Hình 1 – Bầu lựa chọn router – id (1).

Lúc mang lại router R tmê mệt gia OSPF (xem hình 1), router R nên thai lựa chọn ra một ‘niông chồng name’ nhằm định danh R Lúc R chạy OSPF. Vì ‘niông xã name’ này còn có định hình của một can dự IP.. bắt buộc R sẽ mang một trong những tương tác IPhường. trên nó để triển khai Router – id. Như vẫn nói trên, chỉ shop của những interface đang active, Tức là làm việc trạng thái up/up (status up, line protocol up) bắt đầu được ttê mê gia bầu lựa chọn. Ta thấy trên hình , chỉ tất cả nhì cổng F0/0 và F0/1 của R là up/up nên router R đang chỉ cẩn thận nhị cửa hàng bên trên hai cổng này là 192.168.1.1 và 192.168.2.1. Để xác định vào nhị xúc tiến này, ảnh hưởng như thế nào là cao hơn, R tiến hành đối chiếu nhì liên hệ này theo từng octet tự trái lịch sự đề nghị, liên can làm sao tất cả octet trước tiên lớn hơn được xem như là lớn hơn. Ta thấy, với phương pháp đối chiếu này, can dự 192.168.2.1 được xem là lớn hơn tác động 192.168.1.1 cho nên nó sẽ được sử dụng để làm router – id. Vậy R đã tđam mê gia OSPF với giá trị ‘nichồng name’ – router id là 192.168.2.1.

Cũng ví dụ bên trên nhưng lần này trên router R có thêm các interface loopback :

*

Hình 2 – Bầu lựa chọn router – id (2).

Khi ta nhảy OSPF bên trên router R, R xúc tiến bài toán thai lựa chọn router – id. Vì lần này còn có các interface loopbaông chồng phải R vẫn bỏ qua, không xem xét những can hệ của những interface đồ lý. Hai liên can của nhì interface loopbaông xã 1 và 2 sẽ được đối chiếu để chọn ra router – id cho router R, cùng ta thấy cụ thể 2.2.2.2 > 1.1.1.1 đề xuất router R vẫn chọn 2.2.2.2 có tác dụng router – id Lúc tsi mê gia OSPF. Từ hình 2, ta thấy, 2.2.2.2 không phải là địa chỉ IP.. cao nhất dẫu vậy vày các bước ưu tiên cổng loopbaông xã phải các liên can trên những cổng loopbaông xã sẽ tiến hành cẩn thận trước. Vấn đề này được giải thích là đang mang đến sự định hình cho tiến trình OSPF vì chưng interface loopbaông chồng là loại interface luận lý không khi nào down trừ khi bạn quản ngại trị shutdown interface này.

Thực hóa học, vấn đề up/down của những interface ko ảnh hưởng nhiều lắm mang lại router – id của các router chạy OSPF. Thật vậy, giả sử vào ví dụ trên, router R đang chọn xong xuôi router – id là 192.168.2.một là IP.. của cổng F0/1 (xét ngôi trường hợp chưa xuất hiện những interface loopback) cùng tsi mê gia vào OSPF cùng với router – id 192.168.2.1. Hiện nay, trường hợp ta tất cả bổ sung thêm những interface loopbaông xã bên trên router thì router cũng biến thành ko thay đổi lại router – id thành IPhường của những interface loopbaông chồng. hơn nữa, mặc dầu bây giờ cổng F0/1 gồm down, thì router vẫn giữ lại giá trị router – id mà nó vẫn lựa chọn. Có nghĩa là, router – id đối kháng thuần chỉ cần một chiếc thương hiệu. khi tên đã được chọn thì quá trình OSPF đang thao tác làm việc với cái thương hiệu này và ko biến hóa lại nữa. Cổng gồm IPhường được trích xuất làm cho tên của router hôm nay có up/down cũng ko ảnh hưởng gì cả. Vậy giả dụ bọn họ muốn thay đổi lại router – id của quy trình thì sao? Ta cần thực hiện khởi đụng lại router hoặc gỡ vứt quá trình OSPF rồi thông số kỹ thuật lại, khi đó các bước bầu lựa chọn router – id sẽ tiến hành thực hiện lại với những interface đang hiện hữu trên router.

Và điều này, ta thấy vấn đề ưu tiên áp dụng IP. trên loopback có những ý nghĩa về khía cạnh cai quản trị hơn là tính bất biến của quá trình. Nó chất nhận được ngươi quản lí trị kiểm soát và điều hành hiệu quả rộng những router – id của những router.

Có một phương pháp không giống nhằm cấu hình thiết lập lại quý hiếm router – id mang lại router mà không cần thiết phải khởi cồn lại router hoặc thông số kỹ thuật lại OSPF là áp dụng câu lệnh ‘router-id’ nhằm cấu hình thiết lập bằng tay quý hiếm này bên trên router:

Router(config)#router ospf 1

Router(config-router)#router-id A.B.C.D

Trong thời điểm này giá trị của router – id hoàn toàn có thể không cần thiết phải là 1 trong những can dự IPhường tất cả sẵn trên router. Hình như, ví như các bước OSPF sẽ chạy cùng router – id đã làm được tùy chỉnh thiết lập trước đó, ta đề xuất khởi hễ lại các bước OSPF thì mới có thể áp dụng được giá trị router – id mới được chỉ ra vào câu lệnh ‘router – id’. Câu lệnh khởi cồn lại quá trình OSPF:

Router#clear ip ospf process

Rephối ALL OSPF processes? : yes Area – id.Hello timer và Dead timer.Hai liên can IPhường đấu nối buộc phải cùng subnet (một vài ngôi trường hòa hợp còn đề nghị cùng cả subnet – mask).Thỏa mãn các ĐK chính xác.Cùng nhảy hoặc cùng tắt cờ stub.

Ta thuộc so sánh từng thông số kỹ thuật đã nêu sinh hoạt bên trên.

Area – id

Nguyên tắc buổi giao lưu của OSPF là mỗi router đề xuất ghi ghi nhớ bảng đại lý tài liệu trạng thái con đường link của cục bộ hệ thống mạng chạy OSPF rồi trường đoản cú đó thực hiện tính toán thù định đường dựa vào bảng cơ sở tài liệu này. Để bớt mua bộ nhớ cũng như download tính toán cho từng router với bớt thiểu lượng công bố định con đường buộc phải dàn xếp, các router chạy OSPF được phân thành các vùng (area), mỗi router bây giờ chỉ việc đề xuất ghi ghi nhớ thông tin cho 1 vùng mà lại nó ngơi nghỉ trong các số đó (hình 4).

Hình 4 – Kiến trúc phân vùng vào OSPF.

Cách tổ chức như vậy rõ ràng tiết kiệm ngân sách tài nguyên ổn mạng cùng tài nguyên ổn bên trên mỗi router. Bên cạnh đó, giải pháp tổ chức triển khai này còn cô lập được đầy đủ không ổn định vào vào một vùng: Lúc tất cả một liên kết làm sao đó bên trên một router up/down, sự khiếu nại này chỉ lan truyền trong nội cỗ một vùng và tạo ra sự tính toán lại định con đường của những router trong vùng ấy chứ không cần tác động đến các router nằm trong vùng khác.

Mỗi vùng được chỉ ra rằng sẽ có một quý hiếm định danh cho vùng Call là Area – id. Area – id hoàn toàn có thể được hiển thị bên dưới dạng một số thoải mái và tự nhiên hoặc dưới dạng của một ảnh hưởng IP. Vi dụ Area 0 có thể được trình diễn là Area 0.0.0.0. Một nguyên lý phải trong phân vùng OSPF là nếu tạo thành các vùng thì bắt buộc phải sống thọ một vùng sở hữu số hiệu 0 – Area 0, Area 0 còn được gọi là Backbone Area và gần như vùng không giống bắt buộc phải tất cả kết nối nối về vùng 0.

Lúc triển khai cấu hình phân vùng mang lại router, ta không gán cả router vào trong 1 vùng cơ mà thực hiện gán link bên trên router vào một vùng. Area – id được gán mang đến liên kết của router chđọng không hẳn gán đến bản thân router. Ví dụ: trên hình 4, ta thấy toàn bộ router R2 bên trong vùng 0 là do khi thông số kỹ thuật ta vẫn gán nhị liên kết trên R2 vào vùng 0. Những router mà lại tất cả toàn bộ các link những được gán vào trong 1 vùng thì đã lọt hẳn vào vùng kia và được gọi là các Internal router, các Internal router chỉ cần ghi lưu giữ tâm lý con đường link của vùng mà lại nó ở phía bên trong. Ta cũng xét tiếp router R4. Router này còn có một liên kết thuộc vùng 0, lại có một liên kết trực thuộc vùng 1, như thế nó nằm trong về cả nhì vùng và buộc phải ghi ghi nhớ tâm trạng đường links của tất cả nhị vùng. Những router điều này được Call là các router ABR – Area Border Router – router biên cương giữa nhì vùng.

Khi hai router trơn giềng kết nối cùng nhau sang một liên kết, bọn chúng bắt buộc thống duy nhất với nhau về area – id của liên kết này. Cả nhì router yêu cầu gán cùng một số area – id cho link kết nối giữa chúng cùng nhau. Nếu vấn đề đó bị phạm luật, bọn chúng sẽ không còn thể thiết lập cấu hình được quan hệ nam nữ bóng giềng thông qua liên kết này với cho nên vì thế ko khi nào rất có thể hiệp thương được thông báo định đường qua link. Đó là điều kiện đầu tiên trong việc tùy chỉnh thiết lập quan hệ nam nữ láng giềng: thống độc nhất vô nhị về area – id bên trên liên kết liên kết.

Chương trình CCNA không đề cùa tới OSPF đa vùng nhưng mà chỉ nói tới OSPF đối chọi vùng, trong các số đó hồ hết router phần đông được gán vào một vùng. Kiến trúc nhiều vùng cùng các vấn đề cụ thể của chính nó sẽ tiến hành nhắc chi tiết vào course Route của lịch trình CCNPhường.

Hello timer và Dead timer

Hello timer là khoảng thời gian chu kỳ gửi gói tin hello thoát ra khỏi một cổng chạy OSPF. Lúc một router nhận thấy hello từ nhẵn giềng, nó sẽ khởi động Dead timer. Nếu sau khoảng chừng thời hạn được chỉ ra rằng trong Dead timer nhưng router không sở hữu và nhận được gói tin hello từ bỏ trơn giềng, nó đang coi nlỗi láng giềng này không còn cùng vẫn xóa phần đông thông tin nhưng nó học tập được tự trơn giềng. trái lại, cứ mỗi lần nhận ra gói tin hello tự bóng giềng, Dead timer lại được reset. Giá trị khoác định của hello – timer và dead – timer là 10s và 40s. Ta rất có thể hiệu chỉnh những cực hiếm này trên cổng chạy OSPF bằng cách áp dụng câu lệnh:

R(config-if)#ip ospf hello-interval  seconds

Để hai router tùy chỉnh cấu hình được quan hệ giới tính nhẵn giềng với nhau, cặp quý hiếm này bắt buộc phải khớp nhau trên nhì router nghỉ ngơi hai đầu của mặt đường links.

Cùng subnet

Hai can hệ IP1 và IP2 đấu nối nhau giữa nhị router sẽ phải cùng subnet thì nhị router này bắt đầu có thể thiết lập cấu hình quan hệ tình dục láng giềng cùng nhau (coi hình 3). Một số trường đúng theo còn buộc phải hai tác động này bắt buộc cùng cả subnet – mask để rất có thể thiết lập neighbor.

Thỏa mãn authentication

Trong ngôi trường thích hợp để bức tốc tính bảo mật của vận động hội đàm báo cáo định tuyến, chúng ta triển khai cài đặt các pasword trên nhì router nhị đầu mặt đường link. Yêu cầu đề xuất là hai password này phải khớp nhau ngơi nghỉ hai đầu nhằm hai router hoàn toàn có thể thiết lập cấu hình neighbor (tất nhiên!). Cấu hình tuyệt đối không nên hoàn toàn có thể dẫn mang đến ko thiết lập neighbor được giữa nhị router trường đoản cú kia dẫn đến không Bàn bạc được công bố định đường.

Cờ stub

Trong kiến trúc nhiều vùng của OSPF bao gồm một một số loại vùng gọi là vùng stub. Vùng stub là vùng không chào đón LSA type – 5. Lúc ta vẫn cho một link của một router trực thuộc vùng stub thì phải đầu cơ của liên kết cũng bắt buộc gán link này thuộc vùng stub. lúc đó những gói tin định tulặng trao đổi nhau giữa hai đầu sẽ có cờ stub được nhảy lên. Chi ngày tiết về vùng stub được kể cụ thể trong course Route của chương trình CCNPhường., công tác CCNA không cover vụ việc này.

Sau Lúc cả 05 điều kiện nêu bên trên đã có vừa lòng, nhị router thiết lập cấu hình cùng nhau một quan hệ Gọi là quan hệ giới tính trơn giềng với được ký hiệu là 2 – WAY. Khi những router đang thiết lập cấu hình được quan hệ tình dục 2 – WAY cùng nhau, chúng bắt đầu tiến hành đàm phán bảng cơ sở tài liệu tinh thần con đường links (LSDB – Link State Database) cho nhau. Việc trao đổi này được lộn ra toàn mạng cùng cuối cùng từng router đều phải sở hữu được tinh thần đường links của đầy đủ router trong mạng, trường đoản cú đó bọn chúng thực hiện tính toán trên đại lý tài liệu tinh thần con đường link này và xây dừng bảng định tuyến.

Trao đổi LSDB

LSDB – Link State Database – Bảng cửa hàng tài liệu trạng thái con đường links là một trong những bảng bên trên router ghi ghi nhớ đông đảo tinh thần con đường links của hồ hết router trong vùng. Ta rất có thể coi LSDB là một trong những “tnóng bạn dạng đồ gia dụng mạng” mà router đang địa thế căn cứ vào kia nhằm tính tân oán định tuyến đường. LSDB buộc phải hoàn toàn tương đương nhau giữa các router cùng vùng. Các router sẽ không điều đình cùng nhau cả một bảng LSDB nhưng mà vẫn Bàn bạc cùng nhau từng đơn vị chức năng đọc tin call là LSA – Link State Advertisement. Các đơn vị lên tiếng này lại được đựng trong số gói tin cụ thể Điện thoại tư vấn là LSU – Link State Update nhưng các router thực sự hội đàm cùng nhau. Lưu ý: LSA chưa phải là 1 trong loại gói tin mà lại chỉ là một bản tin. LSU bắt đầu đích thực là gói tin với nó chứa đựng các phiên bản tin này.

Việc đàm phán lên tiếng diễn ra khôn xiết khác biệt tùy thuộc vào từng các loại network – type gán đến links thân nhì router. Trong sự cân đối công tác CCNA, họ chỉ xét cho nhì loại network – type là Point – khổng lồ – Point và Broadcast Multiaccess.

Point – lớn – point

Loại link point – khổng lồ – point điển hình nổi bật là kết nối serial điểm – điểm chạy giao thức HDLC hoặc PPP nối giữa nhì router (hình 5).

Hình 5 – Trao đổi LSDB với kết nối point – khổng lồ – point.

Trong trường vừa lòng này, nhị router trơn giềng đã ngay lập tức chớp nhoáng gửi tổng thể bảng LSDB lẫn nhau qua liên kết point – khổng lồ – point và gửi trạng thái dục tình trường đoản cú 2 – WAY sang 1 cường độ bắt đầu gọi là dục tình dạng FULL. Quan hệ Full qua một liên kết serial point – to – point được ký hiệu là FULL/ – .

Broadcast Multiaccess

Môi ngôi trường Broadcast Multiaccess điển hình nổi bật đó là môi trường Ethernet LAN (hình 6).

Hình 6 – Broadcast MultiAccess.

Việc điều đình LSDB diễn ra hoàn toàn không giống trong môi trường xung quanh này. Với môi trường thiên nhiên này, mỗi router phần đông liên kết trực tiếp cùng nhau với gần như tùy chỉnh thiết lập quan hệ giới tính 2 – WAY với nhau. Tuy nhiên, những router sẽ không dàn xếp trực tiếp cùng nhau cơ mà đã thực hiện hiệp thương thông tin thông sang một router mai mối gọi là DR – Designated Router. Trên mỗi liên kết Multi – access, một DR router được thai ra. Một router khác sẽ được thai có tác dụng Backup DR (BDR) để tham dự phòng mang lại DR trong ngôi trường hợp DR down. Các router sót lại vào vai trò là DROther. Ngulặng tắc đề ra như sau: các router DROther Lúc Bàn bạc đọc tin định con đường sẽ không còn gửi thẳng lẫn nhau mà lại đang trình lên đến DR và BDR. Sau kia router DR này vẫn forward lại lên tiếng xuống cho các router DROther khác. khi các router gửi công bố lên đến DR cùng BDR, chúng đang sử dụng liên tưởng multicast 224.0.0.6 còn Lúc DR forward lại thông báo xuống các router không giống, nó sử dụng ảnh hưởng 224.0.0.5. Nhắc lại, các DROther không dàn xếp trực tiếp cùng nhau.

Hình 7 – Hoạt cồn điều đình lên tiếng thông qua DR.

Xem thêm: Phản Biện Tiếng Anh Là Gì - Tư Duy Phản Biện In English

Về quan hệ nam nữ giữa các cặp router từ bây giờ, ta thấgiống như sau:

– Các DROther ko bao giờ thảo luận công bố cùng nhau đề xuất dục tình thân bọn chúng mãi sau chỉ dừng lại ở tầm mức độ 2 – WAY. Thực hiện nay show bảng neighbor bên trên các router DROther sẽ thấy rằng những router này hiển thị tình trạng quan hệ tình dục với nhau là 2-WAY/DROther.

– Các DROther tất cả trao đổi dữ liệu cùng với DR cùng BDR phải vào bảng neighbor của các router DROther, những router DR và BDR vẫn hiện ra cùng với quan hệ dạng full: FULL/DR và FULL/BDR. Ngược lại, các router DR với BDR cũng thấy chứng trạng tình dục của những router DROther cùng với bọn chúng là FULL/DROther.

do đó, router DR đóng một sứ mệnh cực kỳ đặc trưng bên trên môi trường thiên nhiên Multiaccess: chính là router điều păn năn báo cáo trên môi trường thiên nhiên này. Vậy router làm sao sẽ được chọn có tác dụng DR? Ta có cách thức bầu lựa chọn DR với BDR cho 1 môi trường multi – access nlỗi sau:

– Trên mỗi cổng đấu nối multi – access của từng router đều phải sở hữu một giá trị Hotline là priority. Giá trị priority này phía trong dải tự 0 mang lại 255 và được dàn xếp giữa những router trong những gói tin hello. Router nào nắm giữ giá trị priority cao nhất sẽ tiến hành bầu lựa chọn có tác dụng DR, priority cao nhì làm cho BDR, còn sót lại đã là DROther. Giá trị priority mặc định trên các cổng router là bằng 1. Lưu ý rằng giả dụ router có quý giá priority bởi 0 sẽ không còn tsay đắm gia vào tiến trình bầu lựa chọn DR cùng BDR, nó luôn luôn luôn đảm nhận mục đích là DROther.

– Trong trường hợp quý hiếm priority cân nhau (ví dụ nhằm mặc định bởi 1 hết, ko cấu hình gì thêm), router làm sao tất cả Router – id cao nhất đã làm DR, Router – id cao nhị đã có tác dụng BDR, còn sót lại làm cho DROther. Ta nói Router – id là tie – breaker của Priority.

Có một số trong những để ý đến vấn đề bầu chọn DR và BDR như sau:

– Nếu ta cấu hình một router nhấn cực hiếm priority bởi 0, router này sẽ không tmê say gia vào các bước bầu chọn DR cùng BDR, nó luôn luôn luôn là DROther. Chúng ta phải lưu ý vấn đề đó vì chưng ví như bọn họ cấu hình cho tất cả các router đấu nối vào môi trường xung quanh multi – access quý giá priority = 0 thì vẫn không tồn tại router làm sao chịu đựng làm DR mang đến môi trường xung quanh này! Lỗi này dẫn cho lỗ hổng trong việc Bàn bạc ban bố định tuyến đường.

– Luật thai lựa chọn DR là non – preempt: lúc 1 DR đã có thai chọn hoàn thành, trường hợp router bắt đầu tđê mê gia vào môi trường xung quanh multi – access bao gồm priority xuất xắc router – id cao hơn router DR nó cũng cấp thiết chỉ chiếm quyền của DR hiện nay. Chỉ bao giờ DR hiện tại down, router khác bắt đầu gồm thời cơ tranh con quyền DR.

– Một router hoàn toàn có thể đóng những sứ mệnh khác biệt trên nhiều cổng multi – acces không giống nhau. Ví dụ: nó rất có thể là DR trên môi trường xung quanh Multi – access đấu nối vào cổng F0/0 mà lại lại là DROther bên trên môi trường thiên nhiên Multi – acces đấu nối vào cổng F0/1.

– Chúng ta không được lầm lẫn kết nối Ethernet nối 02 router là 1 trong những liên kết point – to – point, kết nối này vẫn được xem như là Multi – access. Trong trường thích hợp này, một router vẫn có tác dụng DR, một làm BDR, không có DROther (hình 8).

Hình 8 – Đây là môi trường xung quanh Multi – access dù chỉ tất cả 02 router.

Sau Khi dứt xong thao tác làm việc điều đình LSDB, mỗi router vào vùng đa số đã chiếm lĩnh bảng cơ sở dữ liệu tinh thần đường link của các router vào vùng, tốt nói một phương pháp không giống, từng router đã sở hữu “tấm bạn dạng vật mạng” của cả vùng. Dựa bên trên LSDB này, những router đã chạy giải mã Dijkstra nhằm xây cất một cây đường đi nlắp duy nhất mang đến hồ hết đích đến trong mạng với gốc cây chính là router ấy. Từ cây này, router kiến tạo lên bảng định tuyến đường của mình. Chi huyết về lời giải Dijkstra xin không nói tại đây. Các các bạn quan tâm có thể tò mò thông qua các giáo trình về Toán thù tránh rộc rạc hoặc Lý thuyết thứ thị của những ngôi trường Đại học. Bài viết này sẽ ra mắt giải pháp OSPF tính tân oán metric cho những lối đi và cách tín đồ quản trị quan sát vào sơ vật dụng mạng để xác định lối đi nhưng OSPF đang lựa chọn mà chưa hẳn “chạy” thuật tân oán Dijkstra trong đầu ^^:

Tính toán thù metric cùng với OSPF

Metric trong OSPF được Gọi là cost, được xác minh phụ thuộc bandwidth danh định của mặt đường truyền theo bí quyết nlỗi sau:

Metric = cost = 10^8/Bandwidth (đơn vị chức năng bps).

Ta phân minh giữa bandwidth danh định trên cổng và vận tốc thiệt của cổng ấy. Hai cực hiếm này sẽ không tuyệt nhất thiết buộc phải trùng nhau cùng cực hiếm danh định new chính là quý giá được tđê mê gia vào tính toán thù định con đường. Giá trị danh định được thiết lập cấu hình trên cổng bởi câu lệnh:

R(config-if)#bandwidth BW(đơn vị chức năng là kbps)

Ta buộc phải chỉnh quý hiếm danh định này trùng với tốc độ thật của cổng để tránh câu hỏi tính tân oán sai trái vào định tuyến. Ví dụ: một con đường leased – line kết nối vào cổng serial chỉ bao gồm tốc độ thiệt là 512kbps tuy vậy giá trị bandwidth danh định trên cổng serial luôn luôn là một trong.544Mbps làm việc khoác định. Điều đó dẫn mang đến OSPF xem một cổng 512 kbps nlỗi một cổng 1.544 Mbps! Ta yêu cầu thiết yếu lại đường truyền danh định trên cổng vào ngôi trường hòa hợp này để đề đạt đúng vận tốc thật:

R(config-if)#bandwidth 512

Dựa vào bí quyết metric đang nêu ở bên trên, ta có giá trị cost mặc định của một vài một số loại cổng:

Ethernet (BW = 10Mbps) -> cost = 10.

Fast Ethernet (BW = 100Mbps) -> cost = 1.

Serial (BW = 1.544Mbps) -> cost = 64 (chặt cho chỗ thập phân trong phxay chia).

Ta cùng xem xét một ví dụ nhằm khảo sát cách tính toán path – cost cho 1 con đường đi:

Hình 9 – Sơ đồ gia dụng ví dụ tính path – cost.

Yêu cầu đưa ra với sơ thứ hình 9 là tính path – cost (metric) đến lối đi trường đoản cú R1 đến mạng 192.168.3.0/24 của R3.

Ta thấy một cách dễ dàng: từ R1 đi mang đến mạng 192.168.3.0/24 của R3 sẽ đi qua những con đường link Fast Ethernet bao gồm cost = 1, serial có cost là 64 và liên kết Fast Ethernet gồm cost bởi 1. Vậy tổng cost tích lũy sẽ là 1 trong + 64 + 1 là 66. Metric tự R1 mang đến mạng 192.168.3.0/24 là 66.

Tuy nhiên Việc tính toán vẫn trsinh hoạt yêu cầu tinh vi rộng trường hợp nhị cổng router làm việc nhì đầu links ko đồng điệu về quý giá cost. lấy ví dụ, ta vào cổng F0/0 của R2 thay đổi lại quý giá cost thành 64 bằng cách đánh lệnh dưới đây trên cổng F0/0 của R2:

R2(config)#interface f0/0

R2(config-if)#ip ospf cost 64

Vậy câu hỏi đặt ra là với link Fast Ethernet nối giữa R1 với R2 ta lựa chọn cost của liên kết này là 1 trong giỏi 64? Nếu lựa chọn là một trong những, tổng cost toàn tuyến đường vẫn duy trì quý hiếm nlỗi cũ là 66, tuy vậy nếu tìm là 64, tổng cost toàn con đường đã là 64 + 64 + một là 129, hai cực hiếm rất khác nhau!

Hình 10 – Tổng path – cost là 66 hay 129?

Để trả lời được câu hỏi này, ta bắt buộc thay nguyên lý sau đâu vào vấn đề tính tổng cost cùng với OSPF:

Để tính tổng cost từ 1 router mang đến một mạng đích theo một con đường (path) nào đó, ta triển khai lần ngược từ đích lần về cùng cùng dồn cost theo phép tắc đi vào thì cộng, rời khỏi thì ko cùng.

Áp dụng phép tắc này cho ví dụ ngơi nghỉ hình 10: để tính tổng cost tự R1 đến mạng 192.168.3.0/24, ta đi ngược trường đoản cú mạng 192.168.3.0/24 đi về. khi trở về ta bước vào cổng F0/0 của R3, cùng quý hiếm cổng này (tổng cost hôm nay là 1); đi thoát ra khỏi cổng S2/0 của R3, bỏ qua ko cộng (tổng cost vẫn là 1); đi tiếp vào cổng S2/0 của R2, cùng giá trị cổng này (lúc này tổng cost là 1 trong + 64 = 65); đi thoát ra khỏi cổng F0/0 của R2, bỏ qua mất ko cùng (tổng cost vẫn luôn là 65); đi tiếp vào cổng F0/0 của R1, cùng giá trị cổng này (tổng cost là 65 + 1 = 66), dứt hành trình. Vậy tổng cost vẫn chính là 66, vấn đề chuyển đổi quý hiếm cost trên cổng F0/0 ko ảnh hưởng gì đến path – cost từ bỏ R1 đi mang đến 192.168.3.0/24.

Hình 11 – Các cổng tđắm đuối gia vào các bước tính tân oán path – cost cùng với OSPF.

bởi vậy với OSPF, nhằm đánh giá đúng được cost của đường đi cùng hoàn toàn có thể hiệu chỉnh cost trên cổng để bẻ lối đi của gói tin theo nguyện vọng, ta rất cần được cẩn thận vào Việc xác định coi cổng làm sao trên đường đi đã tđê mê gia vào tính tân oán để hiệu chỉnh đúng cổng vì hiệu chỉnh bất ổn cổng sẽ không còn mang lại ngẫu nhiên thay đổi gì.

Trên phía trên, bọn họ vẫn với mọi người trong nhà Reviews một trong những nét bao gồm vào buổi giao lưu của OSPF 1-1 vùng trải qua quá trình hoạt động vui chơi của quá trình OSPF: lựa chọn Router – id, thiết lập cấu hình quan hệ bóng giềng, trao đổi LSDB cùng tính tân oán xuất bản bảng định tuyến.

Tiếp theo bọn họ cùng reviews lại cách thức cấu hình OSPF thông qua ví dụ được trình diễn dưới đây.

Cấu hình

Hình 12 – Sơ đồ ví dụ cấu hình.

Trên hình 12 là 4 router đại diện thay mặt mang lại tứ chi nhánh khác biệt của một doanh nghiệp: R1 đến chi nhánh 1, R2 mang đến Trụ sở 2, R3 mang đến Trụ sở 3 với R4 đến Trụ sở 4. Các interface loopbaông xã trên những router thay mặt đại diện cho những mạng nội bộ của từng Trụ sở, sử dụng những subnet trên R1, R2, R3 và R4 thứu tự là 192.168.1.0/24, 192.168.2.0/24, 192.168.3.0/24 với 192.168.4.0/24. Bốn router này đấu nối cùng nhau thông sang 1 kết nối multi – access (đại diện bởi một Ethernet Switch), thực hiện subnet là 192.168.123.0/24 (trên thực tế, trên đây có thể là 1 trong những môi trường Metro net đấu nối thân những bỏ ra nhánh). Router R3 và R4 còn tiến hành đấu nối riêng biệt với nhau bằng một mặt đường leased – line thông qua những cổng serial, thực hiện subnet 192.168.34.0/24.

Yêu cầu đề ra là chạy định con đường OSPF đảm bảo đầy đủ liên quan bên trên sơ thiết bị này thấy nhau.

Để triển khai chạy OSPF trên các router, họ thực hiện câu lệnh sau:

R(config)#router ospf process-id

R(config-router)#network shop IP wildcard-mask area area-id

Trong đó:

Process – id: số hiệu của quá trình OSPF chạy xe trên router, chỉ gồm chân thành và ý nghĩa local trên router

Để cho 1 cổng ttê mê gia OSPF, ta thực hiện “network” liên quan mạng của cổng kia. Với OSPF ta nên sử dụng thêm wildcard – mask để lấy đúng chuẩn subnet tđam mê gia định tuyến. Ta cũng phải chỉ ra links nằm trong area làm sao bởi tsay mê số “area”.

Cấu hình trên những router:

Trên router R1:

R1(config)#router ospf 1

R1(config-router)#network 192.168.123.0 0.0.0.255 area 0

R1(config-router)#network 192.168.1.0 0.0.0.255 area 0

Trên router R2:

R2(config)#router ospf 1

R2(config-router)#network 192.168.123.0 0.0.0.255 area 0

R2(config-router)#network 192.168.2.0 0.0.0.255 area 0

Trên router R3:

R3(config)#router ospf 1

R3(config-router)#network 192.168.123.0 0.0.0.255 area 0

R3(config-router)#network 192.168.34.0 0.0.0.255 area 0

R3(config-router)#network 192.168.3.0 0.0.0.255 area 0

Trên router R4:

R4(config)#router ospf 1

R4(config-router)#network 192.168.123.0 0.0.0.255 area 0

R4(config-router)#network 192.168.34.0 0.0.0.255 area 0

R4(config-router)#network 192.168.4.0 0.0.0.255 area 0

Ta thấy khi mong muốn mang lại cổng F0/0 trên router tsay mê gia OSPF , ta “network” mạng 192.168.123.0/24 trên cổng này. Giá trị wildthẻ – mask được xem đến /24 đang là 0.0.0.255 (nhằm tính được giá trị wildthẻ mask, ta lấy quý giá 255.255.255.255 trừ đi quý giá subnet – mask 255.255.255.0 từng octet một sẽ được tác dụng bắt buộc search. Cách tính này chỉ chuẩn cho một dải IP tiếp tục, không hẳn chuẩn cho hầu như ngôi trường đúng theo. Về wildthẻ – mask sẽ sở hữu một bài viết không giống nhắc chi tiết cho sự việc này). Tương tự với những cổng không giống của những router.

Kiểm tra bằng cách hiển thị bảng định tuyến của các router:

Trên R1:

R1#sh ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:00:29, FastEthernet0/0

O 192.168.34.0/24 <110/65> via 192.168.123.4, 00:00:29, FastEthernet0/0

<110/65> via 192.168.123.3, 00:00:29, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:00:29, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:00:29, FastEthernet0/0

Trên R2:

R2#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:01:20, FastEthernet0/0

O 192.168.34.0/24 <110/65> via 192.168.123.4, 00:01:trăng tròn, FastEthernet0/0

<110/65> via 192.168.123.3, 00:01:trăng tròn, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:01:trăng tròn, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:01:trăng tròn, FastEthernet0/0

Trên R3:

R3#show ip route ospf

192.168.4.0/32 is subnetted, 1 subnets

O 192.168.4.1 <110/2> via 192.168.123.4, 00:02:07, FastEthernet0/0

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:02:07, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:02:07, FastEthernet0/0

Trên R4:

R4#show ip route ospf

192.168.1.0/32 is subnetted, 1 subnets

O 192.168.1.1 <110/2> via 192.168.123.1, 00:21:57, FastEthernet0/0

192.168.2.0/32 is subnetted, 1 subnets

O 192.168.2.1 <110/2> via 192.168.123.2, 00:21:57, FastEthernet0/0

192.168.3.0/32 is subnetted, 1 subnets

O 192.168.3.1 <110/2> via 192.168.123.3, 00:21:57, FastEthernet0/0

Ta thấy rằng những subnet làm việc xa đã có được học trải qua OSPF (những route OSPF được ký kết hiệu bởi ký kết tự “O”).

Một điểm khác biệt chúng ta xem xét là các mạng loopback Lúc hiển thị trong bảng định tuyến của những router hầu hết được OSPF đưa thành /32. Đây là một trong nét trong hoạt động vui chơi của giao thức OSPF, một loại giao thức cung cấp cho từng router một chiếc nhìn tổng quan toàn mạng chứ không hẳn chỉ dựa vào “tin đồn thổi được lan truyền” nhỏng cùng với Distance – vector. Với tầm nhìn như thế, mỗi router khẳng định được mạng loopback nằm ở một cổng không đấu nối đi đâu cả còn chỉ gồm một thúc đẩy của tất cả một mạng được thực hiện. /32 được thực hiện nhằm đề đạt vấn đề đó. Để hạn chế và khắc phục hiện tượng kỳ lạ này cùng khiến cho các subnet loopbachồng được hiển thị giá chuẩn trị prefix –length, ta biến hóa đẳng cấp network – type trên interface loopbachồng thành phong cách “point – khổng lồ – point” bởi câu lệnh:

R(config)#interface loopbachồng 0

R(config-if)#ip ospf network point-to-point

Chi máu về những “network – type “ được thực hiện trong OSPF sẽ tiến hành nói trong những bài viết khác vào khuôn khổ của lịch trình CCNP..

Ta thuộc khảo sát điều tra bảng neighbor trên các router:

Trên R4:

R4#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.3.1 0 FULL/ – 00:00:34 192.168.34.3 Serial2/0

192.168.1.1 1 FULL/DROTHER 00:00:32 192.168.123.1 FastEthernet0/0

192.168.2.1 1 FULL/DROTHER 00:00:34 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:37 192.168.123.3 FastEthernet0/0

Ta thấy, R4 vẫn tùy chỉnh cấu hình quan hệ nam nữ bóng giềng cùng với những router sót lại. Qua cổng F0/0, nó thấy 03 router láng giềng có router – id là 192.168.1.1, 192.168.2.1, 192.168.3.1. Tình trạng quan hệ tình dục cũng chứng tỏ quan hệ giới tính là dạng FULL với mục đích của những router trơn giềng vào môi trường multi – access. Từ công dụng show sinh sống trên, ta thấy cực kỳ rõ ràng router R1 (192.168.1.1), R2 (192.168.2.1) là những DROther router, R3 (192.168.3.1) là BDR router và dĩ nhiên, ta có thể suy ra được R4 chính là DR router. DR thiết lập cấu hình tình dục dạng FULL với tất cả những router trong môi trường multi – access.

Ta cũng thấy rằng R4 cũng thiết lập tình dục láng giềng dạng FULL cùng với R3 qua cổng serial 2/0. Vì đây là cổng point – khổng lồ – point cần các router ko bầu lựa chọn DR và BDR và dục tình giữa nhị router được ký kết hiệu là FULL/-.

Trên R1:

R1#show ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface

192.168.2.1 1 2WAY/DROTHER 00:00:30 192.168.123.2 FastEthernet0/0

192.168.3.1 1 FULL/BDR 00:00:32 192.168.123.3 FastEthernet0/0

192.168.4.1 1 FULL/DR 00:00:31 192.168.123.4 FastEthernet0/0

Trên kết quả show của R1, ta cũng thấy các nhẵn giềng R2 (192.168.2.1), R3(192.168.3.1) và R4 (192.168.4.1) cùng mục đích của từng bé router vào môi trường multi – access. Ta lưu ý rằng R1 chỉ gia hạn quan hệ nam nữ ở tại mức 2WAY với R2, cũng là một DROther giống nó. Hai DROther không bao giờ trao đổi trực tiếp đọc tin định tuyến đường cùng nhau yêu cầu không lúc nào thiết lập được quan hệ giới tính dạng FULL.

Xem thêm: " Christopher Robin Là Ai - Tq Cấm Phim Christopher Robin: Winnie The Pooh

Thực hiện đánh giá tương tự cùng với những router R2 và R3.

Trên trên đây, họ đã cùng review lại chuyển động cơ bản của giao thức OSPF vào công tác CCNA. Đây là 1 trong giao thức khỏe khoắn, quy tụ nkhô cứng, chạy được trên đầy đủ mạng tất cả bài bản béo với nhất là một giao thức chuẩn hóa rất có thể chạy được bên trên các dòng sản phẩm của tương đối nhiều hãng sản xuất không giống nhau cho nên vì thế được áp dụng nhiều trong thực tế. Nắm vững vàng điểm sáng chuyển động cùng cấu hình của OSPF sẽ giúp đỡ bọn họ hoàn thành giỏi kỳ thi đem chứng từ nước ngoài CCNA với thỏa mãn nhu cầu giỏi yêu thương cấu công việc


Chuyên mục: Ý NGHĨA
Bài viết liên quan

Trả lời

Email của bạn sẽ không được hiển thị công khai. Các trường bắt buộc được đánh dấu *